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Viewing Tooltips During Installation
Tooltips are available for all options during installation.
What is the benefit of this enhancement?
When installing Creo applications, all options available during the installation
have tooltips to guide you and to help you better configure your installation.

For example, in the
Application Custom Setting

dialog box for Creo 4.0 and
earlier releases, there are no
tooltips for the options,
making it difficult to
understand which
customization to select.

When installing Creo 5.0,
each option has a tooltip to
guide you.

Additional Information
Tips:

Limitations:

Installation

Place your pointer on an option to see the tooltip.
For additional information at any time during the
installation, click
to open the Installation Help
Center.
No known limitations.
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Does this replace existing
functionality?
Configuration options
associated with this
functionality:

No
None

Silent Uninstall for Creo
When you execute a silent uninstall, you can see the progress of the uninstall.
User Interface Location: From the Creo load point, in the Installmanager
directory, click Silent-Group_uninstall.bat.
What is the benefit of this enhancement?
The file Silent_Group_uninstall.bat, located in the
InstallManager directory was introduced in Creo 4.0. When the .bat file is
executed in Creo 4.0, there is nothing to indicate if the process is running
successfully. In Creo 5.0 you can see the progress of the uninstall.
When Silent_Group_
uninstall.bat is executed you can
see the progress of the uninstall.
Additional Information
Tips:

Limitations:
Does this replace existing
functionality?:

Creo Platform services are uninstalled
after all components that require these
services are uninstalled.
Does not uninstall Creo Schematics
No

Uninstalling Creo Applications
You can uninstall one or all Creo applications at the same time.
User Interface Location: From the Windows control panel, select Programs and
Features to open the Uninstall or change a program dialog box.
What is the benefit of this enhancement?
In Creo 4.0 and earlier releases each application must be uninstalled separately.
The uninstall process can involve completing up to nine uninstall tasks, making
the process time consuming. In Creo 5.0 you can uninstall all Creo applications of
the same version, at the same time.
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In Creo 4.0 and earlier releases, each
application must be uninstalled
separately.

In Creo 5.0, when you select a Creo
application to uninstall, a dialog box
opens. From this dialog box, you can
select to uninstall only the application
you selected or to uninstall all
applications and utilities of the same
version.

Installation
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Additional Information
Tips:

Limitations:

Creo Platform services are uninstalled
after all components that require these
services are uninstalled.
• Does not uninstall Creo Schematics
•

Does this replace existing
functionality?
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You cannot select multiple
applications to uninstall. You must
select one application or all of
them.

No
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Removing Pipe Segments
Use the Remove Pipe Segment tool to reduce the number of pipe segments, cuts,
and welds.
User Interface Location: Click Tools ▶ Remove Pipe Segment.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
The pipeline in the image below has 12 joints requiring 12 weld operations, 6 pipe
cuts, and 6 pipes. After the pipeline is routed and the design is close to final, you
may want to minimize the number of pipes, pipe cuts, and welds. This
minimization helps to reduce costs, optimize manufacturing time, and reduce part
numbers.

Pipeline before removing segment

When you use the Remove Pipe Segment tool, the design is reduced to 4 pipes, 10
welds, and 4 pipe cuts, as you can see in the image below. In addition, you may be
able to reduce the count to 2 pipes, 9 welds, and 2 pipe cuts.

Pipe segments minimized after using
Remove Pipe Segment

Sometimes removing a pipe segment requires the rotation of a fitting to
accommodate the change. When it is required, fittings are automatically rotated.
Click Remove Pipe Segment ▶ Options ▶ Enable fitting rotation to change the
default setting.
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Elbows are automatically rotated.

You do not need to completely remove a pipe segment. Click Remove Pipe
Segment ▶ Edit the pipe segment length.

Partially removed pipe segment

Where there is a break in the pipe, such as when the tee fitting needs to be moved,
you can automatically create a connection joint. Click Remove Pipe Segment ▶
Options ▶ Enable automatic connect.

Tee fitting prior to move, with pipe
break on either side

Tee fitting moved with resulting
automatic pipe connection

Piping
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Additional Information
Tips:
When selecting the boundary of the pipe segment that
you want modify, press SHIFT and click to define the
boundary extents. Alternatively, click Remove Pipe
Segment ▶ References ▶ Details.
Limitations:
You can select only one pipe segment to remove at a
time.
Does this replace
No. This is a new tool.
existing functionality?
Configuration options None
associated with this
functionality:
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IFX Supports Inserting Heli-coils
Intelligent Fastener (IFX) supports the insertion of heli-coils.
User Interface Location: Open the Screw Fastener Definition dialog box.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
A heli-coil inserts provides protection and strengthening for tapped threads in any
material. Bolt tensile strength can be balanced against parent material shear
strength, ensuring bolt failure rather than damage to the parent material.

30 mm heli-coil preview

Additional Information
Tips:
Right-click the heli-coil, to change the heli-coil length.

Limitations:
Does this replace
existing functionality?
Configuration options
associated with this
functionality:
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None
No. This is a new tool.
hole_parameter_file_path—Specifies the
directory path in which to load a standard screw-size
parameter (.hol) file.
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IFX Supports Collapsible Lists
IFX supports collapsible lists for fastener selection.
User Interface Location: Open the Screw Fastener Definition dialog box.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
A fastener library catalog can be large, resulting in a need to scroll to find the
fastener that you want. With a collapsible list, you can define which lists are
collapsed by default and which fasteners appear at the top of the list. This makes
access to fasteners quicker and more efficient.
Creo Intelligent Fastener 4.0

Assembly Design

Creo Intelligent Fastener 5.0
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Additional Information
Tips:
From the ifx_catalogs directory
(<installation location>\common files
\afx\part\ifx_catalogs>) you can open a
catalog.txt file, such as mm-iso.txt, and set the
following:
• Favorites. See yellow highlight.
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•

Groups to be collapsed by default, using the word
collapsed. See pink highlight.

•

Groups to be expanded by default, using the word
expanded. See purple highlight.
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Applying Stripes to Cables and Wires
In Creo Parametric 4.0 and earlier, cables are restricted to one color. In Creo
Parametric 5.0 you can create a library of horizontal and vertical stripes to apply
to wires and cables. Use the Cable Stripes tool to create a library of cable stripes.
User Interface Location:
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
With the increased number of wires in a modern product, when your harness has
more than 10 conductors, it is crucial to be able to identify the wires quickly and
efficiently. With wire striping, cable identification is easy. Striped wire saves you
time when locating wires during installation and maintenance. Striped cable saves
you not only time, but also money.

Vertical stripe

Control the spacing from one end.
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Make the stripes symmetrical.

Control the width of the stripe.

Control the gap between stripes.

Electrical Design
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Add multicolored stripes.

Control spacing, width, and start
position for each stripe, independently.

Add horizontal stripes.
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Additional Information
Tips:
• Stripes are defined in a library which is often
controlled by the administrator. You can create your
own pattern and submit it to the administrator for
approval. If the pattern library file cannot be found,
the cables appear in the default color.
•
Limitations:

•

To control whether the section definition is calculated
by units or percentage, toggle the percentage icon.
You can add up to six different stripe sections.

• Helical stripes are not supported.
No. This is a new tool.

Does this replace
existing functionality?
Configuration options •
associated with this
functionality:
•

Electrical Design

cable_stripes_pattern_file—Sets the
path to the location of the striped appearance .csv
file.
edit_cable_stripes_pattern_file—
When set to yes, you can define new patterns and
edit and save patterns locally. When set to no, you
can use patterns created and defined by the
administrator.
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Element Definition User Interface in AFX
Is Improved
In Creo Advanced Framework, the Element Definition dialog box is easier to use.
User Interface Location: Open the Element Definition dialog box.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In Creo Parametric 4.0 and earlier the Element Definition dialog box contains all
settings and references in one area and it does not include a preview. In Creo
Parametric 5.0 to improve clarity and efficiency, the Element Definition dialog box
is separated into two tabs, References and Settings. From this dialog box, you can
also preview the proposed changes to the connector element and assess the impact
before making the change. This helps to identify potential problems and simplifies
the workflow.

Creo Advanced Framework (AFX)

21

Element Definition dialog box in Creo

Parametric 4.0

Settings tab in the Element Definition

dialog box in Creo Parametric 5.0
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References tab in the Element Definition

dialog box in Creo Parametric 5.0

Preview of the connector element with
the references highlighted in the
Element Definition dialog box in Creo
Parametric 5.0

Creo Advanced Framework (AFX)
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Loft Improvements in Style
You can flip the normal direction of a loft surface from one side of a boundary
curve to the other side.
User Interface Location: Right-click the normal connection symbol on the loft
surface and select Flip Direction.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In Creo Parametric 4.0 and earlier you cannot control the direction of the normal
connection of a loft surface where the boundary curve is planer. As a result, the
surface may not be created as you intended. In Creo Parametric 5.0, the Flip
Direction command gives you the needed control and allows you to flip the
direction of the normal connection of the loft surface. To flip the loft surface to the
other side of the boundary curve, right-click the normal connection symbol on the
loft surface and select Flip Direction.

Start by creating loft surfaces between
the defined curves, such as the two
boundary curves you can see in the
picture to the right.

The loft surfaces are created incorrectly
as the intent was for them to have a
smooth transition.

Surfacing
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Flip the loft surface to the other side of
the outside boundary curve.

Flip the loft surface to the other side of
the middle boundary curve.

Additional Information
None.
Tips:
Limitations:
The following conditions are required to flip a loft
surface:
• You must have a loft surface
•

The Normal connection type must be available. A
normal connection type is a boundary curve with
points and endpoint tangents that are coplanar.

•

The Surface or Surface Connection tab in Style is
open.
No, this is new functionality.

Does this replace
existing functionality?
Configuration options None.
associated with this
functionality:

Mini Toolbar in Style
A context-sensitive mini toolbar containing the commands that are relevant to the
selected item, is added to Style.
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User Interface Location: When you select a curve, surface, or datum, the mini
toolbar appears in the graphics window or the Style Tree.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
The mini toolbar appears close to the pointer when you select a curve, surface, or
datum. This gives you quick access to commands with fewer clicks. Commands
on the mini toolbar vary, based on the type of item you select.
You can access commands on the mini toolbar from either the graphics window or
the Style Tree. For the selected item, the same mini toolbar appears regardless of
where you select the item. You can suit your specific requirements by customizing
the commands on the toolbar. When the mini toolbar appears, a shortcut menu
also opens. From the shortcut menu click Customize.
See examples of mini toolbars for Style below:
Surface

Curve

Datum

Additional Information
Tips:
• Some commonly-used commands, such as Edit
Definition and Suppress, are moved from the shortcut
(right-click) menu to the mini toolbar.
•

For most commands, the mini toolbar provides an
additional method of accessing commands that are
also on the tabs.
None.
The mini toolbar is new for Style.

Limitations:
Does this replace
existing functionality?
Configuration options None.
associated with this
functionality:

Surfacing
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Slice of Shapes by Plane Is Available in
Freestyle
Use the Mesh Slice command to slice shapes by a datum plane.
User Interface Location:
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In addition to the existing mesh slicing functionality, you can slice one or more
shapes by an existing datum plane or by creating a datum plane on the fly. The
selected plane must intersect with the shapes that you want to slice.

The imported datum objects can be made symmetrical using the Mesh Slice and
Mirror commands. After slicing, delete the imperfect sliced shape, and then mirror
the perfect sliced shape to achieve symmetry.

Additional Information
Tips:
You can select shapes on the Freestyle Tree or on the
graphics window. Select Shape in the search filter to
select shapes on the graphics window. You can select
multiple shapes for slicing.
Limitations:
• The hidden shapes are not sliced.
•

28

Multilevel changes are lost while slicing a shape by
plane. You are prompted when such a conflict occurs.
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Does this replace
No. You can use the Mesh Slice command for all slicing
existing functionality? operations.
Configuration options None
associated with this
functionality:

Preview of Imported Objects in Freestyle
Preview the objects before importing them into Freestyle.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
You can preview the object before importing OBJ files in Freestyle. In addition, in
the Import Options dialog box, you can define the following properties:
•

Facet units—Select the facet units from Model, Inch, Foot, Millimeter,

Centimeter, and Meter.
•

Flip normal direction—Flip the direction of the face normals.

The arrows pointing outside of the mesh indicate the direction of the face normals.
You can flip the direction by selecting the Flip normal direction check box. The
Freestyle Tree lists all shapes in the OBJ file being imported, with an indicator to
distinguish them from other shapes. You can also rename these shapes before
importing the object file.

Surfacing
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Additional Information
Tips:
If you do not want to proceed with the object file, click
Cancel in the Import Options dialog box.
None
Limitations:
Does this replace
No. This is new functionality.
existing functionality?
Configuration options None
associated with this
functionality:

Freestyle Surfacing in Box Mode Is
Available
Toggle between standard and box modes to rapidly design your freestyle surfaces.
User Interface Location: In-graphics toolbar
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In Box mode, the control mesh is shaded and not the actual B-spline surface.
Along with the B-spline surfacing, the Box mode surfacing helps you rapidly
create the features, when used effectively.
Surfaces are generated faster in Box mode than the standard mode. As a result,
you do not see any lag in surface creation when you manipulate the control mesh.
This allows you to efficiently perform complex manipulations.

30

What’s New Creo Parametric 5.0

A new icon in the in-graphics toolbar helps you toggle between the modes.

Additional Information
Tips:
If you modify the crease of a mesh in Box mode, toggle
back to standard mode to view the modified mesh
Limitations:
None. You can perform all surface operations in both the
modes.
Does this replace
No. You can toggle between the modes and choose the
existing functionality? appropriate mode when required.
Configuration options None
associated with this
functionality:

Snapping When Adding Edges Is
Improved in Freestyle
With the help of snapping references, you can create accurate mesh in Freestyle.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
When adding a new edge, the target edge on which you place the pointer, is
highlighted. You can select any point on the target edge to complete the new edge.
The snapping references help you to select the precise points on the target edge.

Surfacing
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If the point to be selected satisfies any of the following conditions, one or all three
of the following unique snapping references are displayed:
Indicates the center point on the target edge.
Indicates that the new edge is parallel to an adjacent edge on the same
face.
Indicates that the new edge completes an isosceles triangle on the same
face.
Additional Information
Tips:
Follow the action-object method to view the snapping
references on the initial or the leading edge that you
select to add a new edge.
Limitations:
There are no known limitations.
Does this replace
No. This enhancement improves the current functionality
existing functionality? by providing you more control over selecting points
when adding edges.
Configuration options None
associated with this
functionality:

Align Curvature Is Available in Freestyle
Use Align Curvature to align shapes without losing the curvature continuity.
User Interface Location: Click Freestyle ▶ Align ▶ Align Curvature.
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Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Use Align Curvature to maintain the curvature continuity of the aligned shapes.

Click Align Curvature when aligning surfaces or right-click in the graphics
window and select Curvature to change the noncurvature connection to a curvature
connection.

For every surface connection there is a unique glyph or connection icon. Click the
icon to flip the direction of the connection.

Additional Information
None
Tips:
Limitations:
No known limitations

Surfacing
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Does this replace
No. This improves functionality.
existing functionality?
Configuration options None
associated with this
functionality:

Align to Non-G2 Chains in Freestyle
Use the Align command to align Freestyle edges to external curves or edges with
G0, G1, G2, or G3 connections.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In Freestyle, you can align one-sided open edges to chains of curves or edges of
an external geometry with G0 or G1 surface connections. You can view the
resulting geometry only after completing the Freestyle feature.

If you modify the external geometry, the features are redefined and regenerated.

Additional Information
Tips:
You can view the final geometry only after completing
the Freestyle feature.
Limitations:
No known limitations
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Does this replace
This improves the existing functionality by allowing you
existing functionality? to align to curves with non-G2 surface connections
Configuration options None
associated with this
functionality:

Surfacing
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New Sweep Tool
Use the new volume sweep and helical sweep tools to create accurate 3D
geometric representation for parts that are machined with cutting tools.
User Interface Location: Click Model ▶ Sweep ▶ Volume Helical Sweep.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Creo Parametric 5.0 broadens sweep functionality beyond the 2D sweep
operations that are available in Creo Parametric 4.0 and earlier, by introducing
Volume Helical Sweep. You can accurately model geometry resulting from cutting
tools used in manufacturing operations. Supported use cases cover the grinding
wheel and the screw conveyor scenarios where, in both cases, the sweep is
performed along a helical curve. In both cases, the cutting tool is represented by
an axis-symmetric shape defined by a revolved section. Material is removed
where it intersects the part along its trajectory. From the Volume Helical Sweep
dashboard, you can easily define and control the parameters of the helical
trajectory. You can also easily select, create, or edit the 2D section that defines the
cutting tool, and control available dimensions.
Volume Helical Sweep

From the Volume Helical Sweep tab, you can turn on the display of the sweep
frame and revolved cutting tool. Drag the 3D cutting tool visualization along the
sweep trajectory to easily visualize and quickly understand its movement and
orientation. Unattached and attached previews are available. You can use the
previews to visualize the calculated tool path envelope geometry subtracted from
the part as well as the resulting geometry. With the new Volume Helical Sweep
capabilities in Creo Parametric 5.0, you can model geometry that could previously
only be modeled inaccurately. As a result, there were often downstream issues.

Part Modeling
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Additional Information
Tips:
• You can also use Volume Helical Sweep in a screw
conveyor scenario. Define a helix with constant or
variable helix pitch and apply an adjustment angle of
RX=90 degrees. You can see the results in the
example below:

•

You can use two workflows to define the section of
the cutting tool.
○ Define it within the Volume Helical Sweep
feature.

Limitations:

•

○ Reference an existing sketched section and
specify origin and rotation axis. This
automatically transforms the referenced section
in 3D space to conform with the overall feature
setup such as for the trajectory, adjustment angles
and so on.
Volume Helical Sweep only provides geometric
operations to remove material. You cannot create or
add material.

•

The section that defines the cutting tool may only
contain lines and arcs forming a convex shape.

•

Geometric conditions leading to self-intersections of
the calculated envelope inside the cutting area are not
supported as described in the following cases:
○ When trajectory radius is smaller than the tool
radius
○ For setup and geometry-dependent ranges of
adjustment angles

•

38

The success of the geometric operation may be
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dependent on part accuracy. It is recommended to use
absolute accuracy with values ranging between
0.01mm and 0.001mm.
No.
Does this replace
existing functionality?
Configuration options None.
associated with this
functionality:

Using Sketch Regions
You can use Sketch Region selection to quickly create geometry with selected
sketch-based features.
User Interface Location: Set the selection filter to Sketch Regions.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In Creo Parametric 5.0 there is a new workflow to quickly create geometry with
selected sketch-based features based on Sketch Region selection. A Sketch Region
is a closed contour defined by sketched entities and their intersection with
coplanar 3D edges in the part geometry. Sketch-based feature geometry creation is
faster and easier. Using Sketch Region reduces the need to perform Project and
trim operations within Sketcher. It also offers a flexible way to use portions of a
single sketch as the basis for several sketch-based features.

Part Modeling
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Set the selection filter to Sketch Region
to quickly select one or more sketch
regions. 2D box-selection is available
for sketch regions. Sketched entities
that are involved can belong to different
sketches of the same model. After you
make your selection, a context-sensitive
mini toolbar provides direct access to
the features that support Sketch Region
input: Extrude, Revolve, Fill, and
Sketch. Sketch regions are supported
only for object–action workflow.

Additional Information
Tips:
• Sketch regions provide a faster way to create sketchbased features without the need to prepare the sketch
with Project and trimming operations inside sketcher.
•

Press SHIFT+S to switch to the Sketch Region
selection filter.

•

Limitations:

Press SHIFT+G to switch back to the Geometry
selection filters.
Sketch Region is currently supported in object–action
workflows only. Sketch regions do not represent objects
that can be regenerated. Sketch regions provide a faster
way to create sketch-based features without the need to
prepare the sketch with Project and trimming operations
inside sketcher.
No

Does this replace
existing functionality?
Configuration options None
associated with this
functionality:
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Round Handling in Draft
You can easily apply drafts to design models containing rounds and chamfers.
User Interface Location: Click Model ▶ Draft.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
You can easily apply drafts to design models containing rounds and chamfers.
This addresses the difficulty in Creo Parametric 4.0 and earlier releases in
applying drafts to rounded-base part models from the design department or to
imported models containing rounds and chamfers.
You can select surfaces as references in the Draft surfaces collector of the draft
feature even if they have adjacent rounds or chamfers. Rounds and chamfers are
automatically detected and highlighted in a different color. Rounds and chamfers
are then handled as they are in the Creo Parametric Flexible Modeling
environment. For example, they are implicitly removed before and recreated after
the geometric modification. This allows you to apply drafts to models that already
contain rounds or chamfers at the boundaries of the to-be-drafted surfaces.

Part Modeling
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This enhancement increases productivity through faster creation of drafted
surfaces having adjacent rounds or chamfers.
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Additional Information
Tips:
• If the geometry selection contains inlying rounds,
you can control their inclusion or exclusion from the
draft operation by selecting
on the Draft tab. It
is typically faster and easier to include the inlying
rounds in the selection first, and then to unselect
to exclude them from the drafted geometry.
Select
on the Draft
tab to exclude inlying
rounds. Inlying rounds
then appear in green and
are treated as rounds.
Click to unselect
on
the Draft tab to include
inlying rounds. Inlying
rounds appear in orange,
the modified geometry
color, and are included in
the draft.
•

In addition, you can specify a round surface chain as
a hinge for the draft operation. This can be helpful
for geometric situations such as in the example
below:

•

Options on the Draft tab also includes the Create
round/chamfer geometry check box. When selected,

rounds and chamfers are recreated after the draft
operation. When this check box is cleared, rounds
and chamfers are removed.

Part Modeling

43

Limitations:

•

This enhancement enables the handling of rounds
and chamfers based on previously available
capabilities in Draft. It does not extend the general
capabilities of the draft feature, such as to draft
previously drafted surfaces.

•

This enhancement only supports round and chamfer
types that are currently supported within Creo
Parametric Flexible Modeling.
Draft tangent surfaces moves from under Options to the
Does this replace
existing functionality? Draft tab. Draft features created in Creo Parametric 4.0
and earlier maintain legacy regeneration and user
interface.
Configuration options • draft_tan_propagation_default—
Determines if draft is automatically propagated along
associated with this
tangent
surfaces. Values are yes or no. The default
functionality:
is yes.
•

draft_preserve_inlying_rounds—
Determines if inlying round and chamfer surfaces are
preserved and not to be drafted. Values are yes or
no. The default is no.

Point Pattern Workflow Is Improved
Point pattern workflows are improved when the definition of an alternate origin is
required.
User Interface Location: Click Model ▶ Pattern.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
When the definition of an alternate origin is required, point pattern workflows for
feature patterns are improved, such as in the examples listed below:
•

Point pattern of threaded hole features on a slanted surface referencing a point
of the point pattern array
• Point pattern of sketch-based features referencing a point of the point pattern
array
When you specify the pattern point array during pattern definition, typical
alternate origins are automatically detected. In cases where a point in the point
array is referenced by the pattern leader, this point is automatically set as the
alternate origin reference. The Use alternate origin collector appears on the Pattern
tab. Where autodetection applies, you can see that the Use alternate origin
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collector fills automatically. This enhancement provides a smarter default solution
for point pattern workflows and helps you to correctly define the point pattern
feature.
Additional Information
Tips:
To learn more about the background of this enhancement
and previous issues addressed with this enhancement, see
Support article CS152954.
Limitations:
This workflow only applies to point pattern of features.
You may need to explicitly set the Use alternate origin
collector for a geometry pattern and a flexible pattern
where required. There are no feature references to the
point array.
Does this replace
existing functionality? Creo Parametric 4.0
Pattern user interface.

Creo Parametric 5.0
Pattern user interface. The
Use alternate origin

collector is no longer under
Options.
Configuration options None.
associated with this
functionality:

Mirror Is Enhanced
The Mirror workflow provides an intuitive preview and increased flexibility
during redefinition.
User Interface Location: Click Model ▶ Mirror.
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Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Enhancements to the Mirror tool in Creo Parametric 5.0 result in faster definition
and redefinition of the Mirror feature. A preview in the graphics window is
provided during feature creation or redefinition for immediate visual feedback on
the geometry. In addition, a feature collector is added which alerts you if source
features are missing. When you select the Reapply Mirror check box, missing
features are removed from the definition. Furthermore, the feature collector gives
you the freedom to add or remove features when reapplying the mirror operation.
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Additional Information
Tips:
• You can easily add or remove features from the
mirror operation.
○ Select the Reapply Mirror check box on the Mirror
tab. With Mirrored features active, press CTRL
and select features from the graphics window to
be removed or added.
○ If source features are deleted, they are not
included in the Mirrored features list.
○ If target features are previously modified,
modifications are lost.
•

When references of mirrored features need to be
redefined, they are visible in the feature collector.
See the example below:

•

From the shortcut menu, use Fix to access the
corresponding feature to replace references where
needed.

•
Limitations:

It is recommended to first add and remove features to
the Mirrored features collector before using Fix.
This workflow enhancement is only available in Creo
Parametric part mode and is not supported in
combination with the option Fully dependent with options
to vary.
No, this is new functionality for Mirror.

Does this replace
existing functionality?
Configuration options None
associated with this
functionality:
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Mini Toolbars for 3D Annotations
Mini Toolbars are introduced for 2D and 3D Annotations.
User Interface Location: Click the Annotate tab.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Mini toolbar support in Creo Parametric is broadened. There is full support for
mini toolbars in 3D annotations. As a result, there is faster and more intuitive
command access in object-action workflows. Click a 3D annotation in the
graphics area to see the corresponding context-sensitive mini toolbar. You can
then access available actions without scrolling through the shortcut menu. When
you right-click an annotation both the mini toolbar and the shortcut menu appear.

Annotation mini toolbars are also available when you select annotations in the
Model Tree or Detail Tree.

Model-Based Definition
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You can customize the mini toolbar in either of the ways described below:
•

Right-click an annotation and select Customize from the shortcut menu. Drag
commands to one of the four rows of the Mini Toolbar – Annotation dialog box
to add commands to the mini toolbar. You can also drag commands off the
mini toolbar.

•

Click File ▶ Options ▶ Customize ▶ Shortcut Menus and then select one of the
Annotation names.

Additional Information
To customize the accessibility of mini toolbars, click File
Tips:
▶ Options ▶ Customize ▶ Shortcut menus

Limitations:
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Note
Some commands are moved from the shortcut (rightclick) menu to the mini toolbar.
If you customize the mini toolbar for annotations in the
standard application, the mini toolbar for annotations in
other applications, such as Welding, does not change.
However, if you customize the mini toolbar for
annotations in Welding, for example, the mini toolbar for
the standard application also changes.
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Does this replace
This is new functionality for Model-Based Definition 3D
existing functionality? annotations.
Configuration options None
associated with this
functionality:

Semantic Query in Model-Based
Definition
You can query models per ASME and ISO standards and analyze semantic
information related to annotations.
User Interface Location: Semantic Query is available in the Query group of the
Annotate tab. Semantic Query is also available from the mini toolbar for
annotations.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Semantic Query is a special analysis mode that helps you to obtain the semantic
information related to annotations. Click Annotation ▶ Semantic Query to open
Semantic Query mode. In this mode, you can query annotations and analyze the

complex relationships between the annotations and the geometry in a ModelBased Definition (MBD) environment.
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Additional Information
Tips:
When highlighting annotations in Semantic Query mode,
you can right-click and then from the shortcut menu,
select Add to Combination State to add them to a
combination state.
Note
Semantic Query mode is available in Creo Parametric

Limitations:
Does this replace
existing functionality?
Configuration options
associated with this
functionality:

4.0 M020 and later.
No known limitations
This is new functionality as of Creo Parametric 4.0
M020.
None

Improved Undo and Redo Support in
Model–Based Definition
Support for Undo and Redo is significantly improved for standalone semantic
annotation types, such as dimensions, geometric tolerances (GTOLs), datum
feature symbols and datum targets. You can reliably and easily revert to previous
work states during annotation creation and modification workflows.
User Interface Location: Click Undo or Redo.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Reverting to previous work states during standalone annotation creation and
modification workflows is more reliable and easier. Undo and Redo for commands
relating to standalone semantic annotation types is more robust. For example, you
can use Undo and Redo when creating and deleting standalone annotations and
performing graphical modifications such as movements. You can also use Undo
and Redo when making semantic modifications, such as changing value and text
fields, references, designation attributes, and so on.
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Additional Information
None
Tips:
Limitations:
Enhancements do not include format and actions related
to text style.
Does this replace
This is an improvement to existing functionality.
existing functionality?
Configuration options None
associated with this
functionality:

Improved Failure Notifications for 3D
Annotations
Identify and diagnose failing semantic 3D annotations faster and more intuitively
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Failure notifications is improved for semantic 3D annotations, such as dimensions,
geometric tolerances (GTOLS), datum feature symbols (DFS) and datum targets
(DTD). The improved graphical display of those 3D annotations and missing
references makes it easier to identify the failure and diagnose of what is causing
the failure. The graphical annotation display is color coded and indicates whether
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strong or weak references are missing. Additionally, there are icons in the Model
Tree and Detail Tree indicating the failing annotation. With the improved
graphical display and diagnostics, you can identify and fix failing 3D annotations
faster and more intuitively.
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Additional Information
Tips:
A 3D annotation can fail when it loses a reference or
when it may be otherwise unable to regenerate. The
diagnostic display of failing annotations is color coded in
the following way:
• Orange—Only weak references are missing.
•

Red—At least one strong reference is missing.

You can mark references as strong or weak from the
References dialog box for 3D Annotations.

Limitations:
Does this replace
existing functionality?
Configuration options
associated with this
functionality:

No known limitations.
This is an improvement to existing functionality.
Set the configuration option, highlight_failed_
3d_annotations to yes to control the new graphical
display of failure notifications for 3D Annotations. This
is also useful when printing MBD combination states.

Enhanced Datum Feature Symbol
Attachment Option
You can attach a Datum Feature Symbol (DFS) to a GTOL that is placed on a
dimension.
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Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
You can attach a Datum Feature Symbol (DFS) to a GTOL that is placed on a
dimension. This improves DFS placement compliance to the relating ISO 54592011 and ASME Y14.41-2009 standards.

Additional Information
Tips:
Right-click the datum feature symbol and select other
attachment options.

None
Limitations:
No
Does this replace
existing functionality?
Configuration options None
associated with this
functionality:
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Enhanced Workflow for Radial
Dimensions
The workflow for creating radial dimensions is enhanced. Defining radial
dimensions is faster, easier, more visual, and intuitive.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Typical creation of a radial dimension provides for up to four flip states that
represent different witness line and arrow configurations.
In Creo Parametric 5.0 the definition of flip states is improved to provide better
default states, depending on the position of the pointer. As a result the desired
solution is provided faster and with fewer clicks. Visual feedback reduces the need
to perform subsequent flip operations to get to the desired state.
When creating the radial dimension, move the pointer to different locations to see
an update of the default arrow state. Middle-click to place the dimension. See the
examples below:
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Additional Information
Tips:
You can flip to different arrow states using the methods
described below:
•
•
•

Limitations:
Does this replace
existing functionality?
Configuration options
associated with this
functionality:
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Click Flip on the Dimension tab.
Select the dimension and then right-click to toggle
through the states.
Click Flip Arrows on the mini toolbar.

None
This replaces the workflow for creating radial
dimensions in Creo Parametric 4.0 and earlier.
None
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New Types of Corner Reliefs
New types of corner reliefs provide more geometrical solutions.
User Interface Location:
•

In the Shapes group click Flange ▶ Relief and then select Corner Relief.

•

Click Flexible Modeling ▶ Sheet Metal Objects ▶ Edit Corner Relief.

•

Click Flexible Modeling ▶ Sheet Metal Objects ▶ Recognize Corner Reliefs.

Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
You have more control when creating or modifying corner reliefs. When defining
a corner relief using Flange or modifying a corner relief with the Edit Corner Relief
tool when working in Flexible Modeling, you can select additional shapes such as
Normal and Square. For orientation of the shape, Bisector and Diagonal are added.
The Origin options, Corner point and Bend lines intersection, help you to position
the shape. The Orientation and Origin options are also available for other shapes
such as Circular, Rectangular or Obround.
New shapes are available when creating or modifying corner reliefs:

Normal—Normal creates a cut from the

corner and up to and normal to the bend
end.

Square—Square creates a cut which is

concentric with the relief anchor point
reference and its section diagonal is
parallel to the relief orientation
reference.

See the Relief dialog box below for an example of new shape types:
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Draggers are added to control the length, position, and offset value when defining
a square–shaped corner relief.
Origin Options

Corner Point

Sheet Metal

Bend Lines
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Orientation Options

Bisector

Direction is the bisector of the bend
edges at the corner point.

Diagonal

Direction is defined by the intersection
of the bend lines and the corner point.

The Edit Corner Relief tool gives you more flexibility to change corner reliefs in a
sheet metal part in an intuitive and easy way, independent of how the corner relief
was created.
In addition, the recognition of corner reliefs also includes the recognition of
Orientation and Origin options independent of how the part was created. This also
applies to parts created in another CAD system.
Additional Information
Tips:
In complex corner cases, when a normal shape is not
possible, a V Notch relief is created instead.
None
Limitations:
Does this replace
This enhances the functionality for existing tools.
existing functionality?
Configuration options None
associated with this
functionality:

Flattened Representation of Sheet Metal
Part Is Improved
Defining a flat pattern representation of a sheet metal part is improved and
simplified.
User Interface Location: In the Graphics toolbar click Flat Pattern Preview.
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Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
The process of defining a simplified representation of a sheet metal part in the
flatten state, while having the master representation in the formed (bent) state is
simplified. You can easily switch from a bent to a flattened state when modeling a
sheet metal part. No additional Windchill business object is created or required.
The process is outlined below:

Create a flat pattern preview.

Create a representation.

Name the representation.

Sheet Metal
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Select the newly created representation.

Activate the new simplified
representation.

Additional Information
Tips:
You can create only one flat pattern representation.
Limitations:
No known limitations.
Does this replace
This is an enhancement to existing functionality.
existing functionality?
Configuration options None.
associated with this
functionality:

Conversion Is Improved
The conversion tool is improved to support conversion of solid parts into sheet
metal parts even if the parts contains nonuniform thickness.
User Interface Location: Click Model ▶ Operations ▶ Convert to Sheetmetal.
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Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
When you use the enhanced Convert to Sheetmetal tool, you can convert solid
parts into sheet metal parts and enforce uniform thickness. The improvements
support the import of sheet metal parts from legacy systems and the conversion
into valid Creo Parametric sheet metal parts.
The enhancements give you more control over the conversion. After defining the
first wall and using automatic thickness detection, you can perform the following
actions:
•

Manually overwrite the calculated thickness

•

Include additional surfaces or exclude surfaces

•

Keep, remove, or ignore the adjacent rounds and chamfers

•

Keep nonclassified surfaces as separate quilts

•

Troubleshoot for additional guidance

See the different stages of the part below:

Solid part in Creo Parametric

Result after selecting the driving
surface and first wall

Sheet Metal
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Visual feedback after adding more
surfaces

Final Result

Under Options you can make selections regarding the treatment of adjacent rounds
and chamfers.

See descriptions of these options below:
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Recreate—Rounds and chamfers are

recognized and recreated.

Remove—Rounds and chamfers are

removed and a sharp edge is created.

Ignore—Rounds and chamfers are

recognized and side faces are trimmed
back by the size of the round or
chamfer.

Additional Information
Tips:
There is no support for flushed hem and piercing forms.
Limitations:
No known limitations.
Does this replace
This is an enhancement to existing functionality.
existing functionality?
Configuration options None.
associated with this
functionality:

Closed Section for Bend Relief
You have more control when creating closed sections for bend reliefs.
User Interface Location:

Sheet Metal
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•

Click Model ▶ Flange ▶ Relief.

•

Click Model ▶ Flat ▶ Relief.

•

Click Model ▶ Editing ▶ Join ▶ Relief.

•

Click Flexible Modeling ▶ Edit Bend Relief ▶ Shape.

Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
You have more control when creating or modifying bend reliefs. When defining a
bend relief with a rectangular or oblong shape, you can control the length of
shape. In Creo Parametric 5.0 there are more geometrical solutions available than
in earlier releases.
There are three new options to control length:
Rectangular Relief

Rectangular Relief

Rectangular Relief

Blind

To Next

Through All

See an example of the Relief dialog box below:

68

What’s New Creo Parametric 5.0

Draggers are added to control the length of the rectangular or oblong shape.
Recognition of bend reliefs (Flexible Modeling ▶ Sheet Metal Objects ▶ Recognize
Bend Reliefs) includes Blind, To Next, and Through All. Recognition is independent
of how the part was created. This also includes parts imported from another CAD
system.
Additional Information
Tips:
When defining the length of a bend relief, ensure the
length is greater than the relief depth.
Limitations:
There are no known limitations.
Does this replace
This is an enhancement to existing functionality.
existing functionality?
Configuration options None
associated with this
functionality:

Improved Rounds and Chamfers for
Flexible Modeling
The treatment of rounds and chamfers during Flexible Modeling operations in
Sheetmetal is improved.
User Interface Location:
•

Click Flexible Modeling ▶ Pull Wall ▶ Adjacent Conditions ▶ Create rounds/
chamfer geometry.

•

Click Flexible Modeling ▶ Edit Bend ▶ Adjacent Conditions ▶ Create rounds/
chamfer geometry.

•

Click Flexible Modeling ▶ Edit Corner Seam ▶ Options ▶ Create rounds/chamfer
geometry.

Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
You have more control when working with Flexible Modeling operations affecting
corner seams with adjacent rounds and chamfers. The automatic recognition of
design intent provides the most obvious results. For additional control, use Create
round/chamfer geometry when working with Flexible Modeling, Pull Wall, Edit
Bend, and Edit Corner Seam.
See the examples below of using Create round/chamfer geometry with Flexible
Modeling operations:
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Pull Wall

Edit Bend

Edit Corner Seam

Additional Information
None
Tips:
Limitations:
No known limitations
Does this replace
This is an enhancement to existing functionality.
existing functionality?
Configuration options None
associated with this
functionality:
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Transferring Configurations from Creo
Elements/Direct to Explode States
When importing a Creo Elements/Direct 3D model to Creo Parametric, existing
configurations in Creo Elements/Direct are automatically transferred to explode
states in Creo Parametric.
User Interface Location: Click Open and then in the Type box, select Creo
Elements Direct.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
You can use additional data from Creo Elements/Direct in Creo Parametric when
converting 3D models. You can use operations from Creo Elements/Direct in Creo
Parametric. The conversion of a configuration into to Creo Parametric supports
the following:
•

Alternative positions of components in an assembly explode state

•

Orientation of the configuration

•

Showing and hiding of components of a configuration

•

Transfer of configurations in Creo Elements/Direct to an explode State or
combined state

•

Support of multiple configurations for an assembly

The following shows a configuration in a Creo Elements/Direct model imported to
Creo Parametric:

Default state in Creo Parametric

Explode state in Creo Parametric
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Additional Information
None.
Tips:
Limitations:
When hiding or showing multiple levels, such as an
assembly and its components, the results may not exactly
match with the results in Creo Elements/Direct.
Does this replace
This is an enhancement to existing functionality.
existing functionality?
Configuration options None
associated with this
functionality:

Improved Associative Drawing Import
from Creo Elements/Direct
User Interface Location: Click File ▶ Open and then in the Type box select Creo
Elements Direct Drawing.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Associative drawing import saves time when creating drawings in Creo
Parametric for imported Creo Elements/Direct 3D models with associative
drawings. This improvement strengthens the transfer of more complex drawings,
associatively. Improvements are listed below:
•
•

Centerlines in Creo Elements/Direct drawings are transferred as an axis in
Creo Parametric along with the associative references for dimensions.
Support for views containing Creo Elements/Direct Configurations.
See examples of these improvements below:
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Creo Elements/Direct drawing
containing centerlines transferred as
an axis in Creo Elements/Direct

Creo Elements/Direct drawing with a
front view, with the front view
containing an exploded state

Additional Information
None
Tips:
Limitations:
No known limitations
Does this replace
This is an enhancement to existing functionality.
existing functionality?
Configuration options Set enable_rt_6400852 to yes for support for views
associated with this
containing Creo Elements/Direct configurations and
functionality:
explode states. This configuration option is required for
Sneak Peek only.
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Simplified Visualization and Mass
Properties Calculation in Additive
Manufacturing
Additive Manufacturing Extension (AMX) supports an improved symbolic
representation of lattices.
User Interface Location: On the Lattice tab, select Simplified.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In Creo Parametric 4.0 the simplified representation of a beam-based lattice is
constructed by lines connecting each node, and the material properties calculation
is not supported for simplified lattices. In Creo Parametric 5.0 the simplified
representation is improved to more accurately represent the lattice, as you can see
in the image below:

This enhancement expands the capabilities of the simplified lattice. The simplified
lattice represents a method to quickly run design analysis cycles to speed up the
development of light–weight parts that fulfill structural and thermal requirements.
Additional Information
Tips:
Use this simplified representation to run all the initial
simulation experiments. You can switch to a full
representation, later in the process.
Limitations:
The mass properties calculated by this method for the
simplified lattice is an approximation. Run the mass
properties calculation on the full lattice representation to
get the accurate result.
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Does this replace
Yes. This replaces the previous simplified–
existing functionality? representation–for–lattice functionality.
Configuration options None
associated with this
functionality:

Support for Conical Beams from Additive
Manufacturing in Creo Simulate
There is support in Creo Simulate for conical beams that are defined in symbolic
representations in Additive Manufacturing.
User Interface Location: On the Lattice tab select Simplified. Then, create a
variable density lattice with conical beams.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In Creo Parametric 5.0 there is support in Additive Manufacturing for the
simplified representation of conical beams to be automatically transferred to Creo
Simulate.
Simplified Representation of
Transferred to Creo Simulate
Conical Beams in Additive
Manufacturing

Manufacturing
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This enhancement expands the capabilities of the simplified lattice. The simplified
lattice represents a method to quickly run design–analysis cycle, to speed up the
development of light–weight parts that fulfill structural and thermal requirements.
Additional Information
Tips:
Use this simplified representation to run all the initial
simulation experiments. You can switch to a full
representation, later in the process
Limitations:
Analyses calculated by this method for the simplified
lattice is an approximation. Run the analysis calculations
on the full lattice representation to get the accurate result.
Does this replace
Yes. This replaces the previous simplified–
existing functionality? representation–for–lattice functionality.
Configuration options None
associated with this
functionality:

Support for Truss Lattice in Additive
Manufacturing
Additive Manufacturing Extension (AMX) supports the Truss cell type.
User Interface Location: On the Cell tab, in the Cell Configuration box, select
Truss.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
This enhancement expands the capabilities related to additive manufacturing. In
Creo Parametric 4.0 and earlier, Truss cell types are not available. In Creo
Parametric 5.0, requirements for stiffness and strength-to-weight ratio are met
with the addition of the truss lattice.
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Additional Information
Tips:
You can select inner truss beams, outer truss beams, or
both:

Outer

Inner
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Both

Limitations:
No known limitations.
Does this replace
This is a new tool.
existing functionality?
Configuration options None.
associated with this
functionality:

Support for Thermal Loads in Additive
Manufacturing
There is support for thermals loads on lattices that are defined in symbolic
representations.
User Interface Location: In Creo Simulate thermal mode, click the Heat Load tab.
In the Heat Load dialog box, from the References list, select Lattice Feature.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In addition to the improved support for the symbolic representation of lattices,
there is also support for thermal loads on lattices defined in a symbolic
representation. The support for thermal loads is visible when you are working in
Creo Simulate. The simplified representation of lattices supports thermal loads
when transferred to Creo Simulate. See the image below:
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This enhancement expands the capabilities of the simplified lattice. The simplified
lattice represents a method to quickly run design-analysis cycles to speed up the
development of light-weight parts that fulfill structural and thermal requirements.
Additional Information
Tips:
Use this simplified representation to run all the initial
thermal simulation experiments. Later in the process,
switch to a full representation.
Limitations:
All analyses calculated by this method for the simplified
lattice are an approximation. Therefore, you should run
the analysis calculations on the full lattice representation
to get the accurate result.
Does this replace
This replaces previous simplified representations for
existing functionality? lattices.
Configuration options No configuration options. Requires an Additive
associated with this
Manufacturing Extension (AMX) license and a Creo
functionality:
Simulate license that includes Thermal Simulation.
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Highlighting Toolpaths in Subtractive
Manufacturing
In Creo machining extension, the toolpath, references, or both are highlighted
when you click in the Model Tree.
User Interface Location: In the Model tree, right-click a toolpath and then select
one or both of the icons.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
When you click in the Model Tree, the corresponding toolpath, reference, or both
are highlighted in the graphics area. The selected toolpath or reference remain
highlighted until you click the icons in the Model Tree again. In previous releases,
many clicks are required to identify toolpaths and references. In Creo 5.0,
toolpaths and references are easy to identify.
Display NC Toolpath

Show NC Reference

Additional Information
None
Tips:
Limitations:
You must click the operation and execute the playpath
command on all the toolpaths included. Then, you can
execute this command.
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Does this replace
No. This is a new tool.
existing functionality?
Configuration options No configurations options are required. A Creo NC
associated with this
license is required.
functionality:

Predefined NC Parameters in Subtractive
Manufacturing
In Creo machining extensions you can automatically calculate NC parameters
based on the geometric values for the tool.
User Interface Location: Formulas are included by default in Creo NC.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
It is easy to create NC toolpaths. Select the tool and references to see an NC
toolpath in the graphics area.
Additional Information
None
Tips:
Limitations:
Only tool information is used to feed the formulas and to
calculate the parameter values. Calculation of turning
parameters is limited.
Does this replace
No. This is a new tool.
existing functionality?
Configuration options No configurations options are required. A Creo NC
associated with this
license is required.
functionality:

Slice by Slice in Volume Milling
(Subtractive Manufacturing)
The volume milling toolpath sequence is improved. In addition to machining
region by region in a multipocket toolpath, you can also machine slice-by-slice.
User Interface Location: In volume milling toolpath, click Tool Motions to open
the Volume Milling Cut dialog box. In the Cut type list, select Full Depth Cut.
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Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In the Volume Milling Cut dialog box, the By Region check box is selected by
default. Clear this check box to enable slice-by-slice in a multipocket scenario.
Additional Information
None
Tips:
Limitations:
No known limitations.
Does this replace
No. This is a new tool.
existing functionality?
Configuration options None
associated with this
functionality:
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Modern User Interface for Conventional
Milling (Subtractive Manufacturing)
The user interface for the toolpath sequence for conventional milling is in a ribbon
user interface
User Interface Location: Click Mill ▶ Milling ▶ Conventional Milling.

Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In Creo 5.0 there is a modernized Conventional Milling ribbon making it easier and
more intuitive to perform conventional milling actions. This new user interface
corresponds to the Straight Cut command on the menu manager in earlier releases.
Additional Information
None
Tips:
Limitations:
In Creo 5, only the Straight Cut command is converted to
the ribbon.
Does this replace
This replaces the previous surface milling, straight cut
existing functionality? command.
Configuration options None.
associated with this
functionality:

Modern User Interface for CMM
(Subtractive Manufacturing)
In Coordinate Measuring Machines (CMM), the reference coordinate system and
CMM Construct Step functionality is accessible from a new ribbon.
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User Interface Location:
•

Click Inspect ▶ Reference Coordinate System.

•

Click Inspect ▶ Construct.

Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
In previous releases, this functionality is accessible from the Menu Manager. This
improvement to the user interface provides a more intuitive and efficient way to
perform CMM tasks.
Additional Information
None
Tips:
Limitations:
This conversion to the ribbon for CMM is for Ref Csys
and Construct only.
Does this replace
The functionality is the same but with a new user
existing functionality? interface.
Configuration options None
associated with this
functionality:
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Additional Commands for Showing and
Hiding
There are additional commands for showing and hiding objects.
User Interface Location:
•

Right-click an object in the Model Tree or Graphics window and select Show
All or Show All Except from the shortcut menu or the mini toolbar.

•

Click View and then in the Show box select Show All or Show All Except.

Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
The commands Show All and Show All Except are introduced:
•

Show Only—Shows the selected object. All other objects of the same type are

hidden.
•

Show All Except—Does not show the selected object. All other objects of the

same type appear.

These commands are available in Part and Assembly and provide easier control
over visibility, by the type of object.
Additional Information
Tips:
Click View ▶ Reset Status to reset to the original
visibility configuration.
Limitations:
No known limitations.
Does this replace
This is additional show and hide functionality.
existing functionality?
Configuration options None
associated with this
functionality:
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Diagnosing Failures in Mechanism
Diagnostics and suggested resolutions are available during Mechanism failures.
User Interface Location: Access reports from the Notification Center or from the
Mechanism Disconnected warning.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
During a Mechanism failure you receive messages reporting detailed diagnostics
and suggestions for resolution so that you can better understand the issue. These
messages appear when any of the following occurs:
•

The model is disconnected as a result of regeneration.

•

The mechanism analysis fails to connect.

•

The mechanism fails during dragging.

When a failure occurs, a pmech_conn_regen.err or pmech_conn.err
file is created. These files contain the error information. You can access these files
through the Notification Center or by clicking Details in the Mechanism
Disconnected warning.
•

pmech_conn_regen.err file—Contains errors resulting from
regeneration. To view this file, click the diagnostic icon in the Notification
Center.

•

pmech_conn.err—Contains all other errors resulting from a drag failure,
analysis failure, and so on. To view this file, click Details on the Mechanism
Disconnected warning.
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Additional Information
None
Tips:
Limitations:
No known limitations.
Does this replace
existing functionality?
Configuration options None
associated with this
functionality:

Automatic Meshing Refinement
In Creo Simulate, the adjustment for the refinement of meshing for shell elements
is automatic.
User Interface Location: Click Refine Model ▶ AutoGEM ▶ Create.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Automatic refinement is the default. This enhancement provides a way to
calculate smoother test results automatically. See the image below comparing
results in earlier releases to Creo Simulate 5.0.

Additional Information
None
Tips:
Limitations:
No known limitations
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Does this replace
No. This is a new tool
existing functionality?
Configuration options None
associated with this
functionality:

Support for Detailed Stresses
There is support for detailed stresses for a given contact interface.
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User Interface Location: In Structure mode, click Refine Model ▶ Connections ▶
Interface. In the Interface Definition dialog box, in the Type box, select Contact and
in the Friction box, select Finite.

Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
Detailed Stresses is supported only for finite friction interfaces. When Detailed
Stresses is set, it overrides the global model and analysis-level detailed stresses

setting for this given interface. This enhancement gives you the option of using a
detailed stresses setting on selected important interfaces. This setting helps to
improve the quality of the stress result on a given interface.
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Additional Information
Tips:
When Detailed Stresses is set, the engine uses the
interface-level detailed stresses setting instead of the
global model-level detailed stresses setting. Detailed
stresses require more computation time so be selective
when using it.
Limitations:
Using this setting on many interfaces will result in longer
run time.
No
Does this replace
existing functionality?
Configuration options None
associated with this
functionality:

Support for User-Defined Output Measure
There is support for a user-defined output measure to output maximum penetration
for an engine on a given interface.
User Interface Location: In Structure mode, click Home ▶ Run ▶ Measures. In the
Measure dialog box click New. In the Measure Definition dialog box, under
Quantity, select Interface and Max_Penetration.
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Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
This enhancement gives you more information and visibility about maximum
penetration an engine uses on a given interface. You can check whether this actual
penetration by the engine is acceptable from a design point and then take
appropriate actions.
Additional Information
Tips:
Use this measure when you want to review the level for
maximum penetration on a given interface. If penetration
is more, you can tighten the input maximum for the
penetration that you specify on this interface.
Limitations:
The maximum penetration the engine uses may override
the under-input levels for maximum penetration. The
engine may override maximum penetration guidelines
that you specify, based on valid convergence
requirements.
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Does this replace
existing functionality?
Configuration options
associated with this
functionality

No
sim_contact_penetration—Specify the value of
depth for contact penetration depth in a percentage
greater than 0.0 through 100.0. The default is 5.0.

Support for User-Defined Level for
Contact Interface
There is support for a user–defined level for maximum penetration, for a given
contact interface. This interface property is supported for all contact interfaces:
None, Infinite Friction, and Finite. If used, this overrides the global model-level
contact penetration for the given interface.
User Interface Location: In Structure mode, click Refine Model ▶ Connections ▶
Interface. In the Interface Definition dialog box, under Type, select Contact.
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Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
You can specify the maximum contact-penetration guideline on selected important
interfaces. This interface-specific level of penetration helps to tune your contact
models closer to reality.
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Additional Information
Tips:
When you specify the level for maximum penetration,
for a given contact interface, the engine uses your
specification instead of the global model-level guidelines
for maximum penetration. You should make this
specification on important interfaces.
Limitations:
The tighter levels for penetration on any interface may
result in convergence difficulties.
No
Does this replace
existing functionality?
Configuration options sim_contact_penetration—Specify the value of
associated with this
depth for contact penetration depth in a percentage
functionality:
greater than 0.0 through 100.0. The default is 5.0.

Support for User-Defined Output Measure
for Quality Index
There is support for user-defined output measure to output the quality index of the
interface.
User Interface Location: In Structure mode, click Home ▶ Run ▶ Measures. In the
Measure dialog box, click New. In the Measure Definition dialog box under
Quantity, select Interface and Quality Index.
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Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
This enhancement gives you more information and visibility about the quality of
the interface. You can check whether this interface is adequately meshed to give
quality results. This measure reports a value in the range of zero to one (0-1). Zero
(0) is a poor mesh and one (1) is a good mesh.
Additional Information
Tips:
Use this measure when you want to review mesh quality
on s given interface. If the value of this measure is < 1,
then you should consider refining the mesh on this
interface by adding the appropriate AutoGEM control.
Or, you can improve the mesh quality by using a mapped
mesh.
Limitations:
The overall interface quality depends on the mesh quality
and on the nature of contact. A contact between curved
edges or surfaces that results in a contact area near zero,
can also impact the interface quality.
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No
Does this replace
existing functionality?
Configuration options None
associated with this
functionality:

Solver Accuracy Settings for Contact
Analysis
There is support for different solver accuracy levels for contact analysis. For small
deformation analysis (SDA) contact analysis, there are two accuracy levels:
Medium and High. For large deformation analysis (LDA) Contact Analysis, there
are three accuracy levels: Low, Medium, and High.
User Interface Location: In Structure mode click Home ▶ Analyses and Studies.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
This enhancement gives you more control over the solution accuracy of contact
analysis. In initial design phases, when seeking approximate solutions, you can
use Low or Medium accuracy. When finalizing designs, you can then switch to
High accuracy. This helps to save time and cost.
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SDA Contact Analysis

LDA Contact Analysis

Additional Information
Tips:
Use this contact solver accuracy setting to help save
solution time in initial design stages. The default
medium accuracy in LDA and SDA contact analysis is
sufficient and results are reasonable.
Limitations:
The High accuracy settings for contact solver may
require a longer solution time. The solution may not
converge if you have tight penetration requirements on
important interfaces. Also, the models with a low
measure value for the interface quality index, may have
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difficulty during convergence.
No

Does this replace
existing functionality?
Configuration options None
associated with this
functionality:
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Round Handling in Draft in Creo Direct
You can easily apply drafts to design models containing rounds and chamfers.
User Interface Location: Click Home ▶ Draft.
Watch a video that demonstrates this enhancement:
What is the benefit of this enhancement?
You can easily apply drafts to design models containing rounds and chamfers.
This addresses the difficulty in Creo Direct 4.0 and earlier releases in applying
drafts to rounded-base part models from the design department or to imported
models containing rounds and chamfers.
You can select surfaces as references for the Draft tool even if they have adjacent
rounds or chamfers. Rounds and chamfers are automatically detected and
highlighted in a different color. Rounds and chamfer handling is then applied as it
is for other Creo Direct modeling tools such as Move and Offset. This allows you
to apply drafts to models that already contain rounds or chamfers at the
boundaries of the to-be-drafted surfaces.

This enhancement increases productivity through faster creation of drafted
surfaces having adjacent rounds or chamfers.
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Additional Information
Tips:
• If the geometry selection contains inlying rounds,
you can control their inclusion or exclusion from the
draft operation by selecting
on the floating
dashboard. It is typically faster and easier to include
the inlying rounds in the selection first, and then to
select
to exclude them from the drafted
geometry.
on the
Select
floating dashboard to
exclude inlying rounds.
Inlying rounds then
appear in green and are
treated as rounds.
Click
on the
floating dashboard to
stop the select operation
and to include inlying
rounds. Inlying rounds
appear in orange, the
modified geometry color,
and are included in the
draft.
•
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You can specify a round surface chain as a hinge for
the draft operation. This can be helpful such as in the
example below:
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•

Limitations:

•

•

Click or clear the Create round/chamfer geometry
check box on the floating dashboard. When this
check box is selected, rounds and chamfers are
recreated after the draft operation. When this check
box is cleared, rounds and chamfers are removed.
This enhancement enables round and chamfer
handling based on previously available functionality
of the Draft feature. It does not extend the general
functionality of the Draft feature, such as to drafting
previously drafted surfaces.
This enhancement supports round and chamfer types
that are currently supported within Creo Direct.

No
Does this replace
existing functionality?
Configuration options To be determined.
associated with this
functionality:
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